Bonjour Mr. le visiteur, si vous lisez ceci, cela signifie que vous n'êtes pas enregistré. Cliquez ici pour vous inscrire en quelques étapes simples, vous pourrez profiter de toutes les fonctionnalités de notre Forum. Vous pourrez évidemment nous faire partager vos connaissances avec nous ! et voir les images ou vidéos postées



Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Elfin EE10 - Convertisseur RS232 <--> Ethernet RJ45 pour nos onduleurs
#1
Voilà j'ai reçu le petit convertisseur Elfin EE10    RS232 <---> RJ45 Ethernet.

   

J'ai câblé la bestiole et cela fonctionne parfaitement Shy ****
Maintenant mon onduleur est connecté directement sur Ethernet en filaire. Plus besoin de USB ni de WiFi. :Smiley_20040821172041111:

Même pas besoin de modifier mon logiciel car le boîtier fonctionne avec les mêmes "settings" que la version Wifi (sauf la partie wifi évidemment)
Une solution vraiment élégante sans se ruiner. (22€ chez Amazon, évidemment moins chez Ali)

Du coup on peut mettre le Raspberry dans le salon (ou ailleurs)
ou utiliser une machine virtuelle sans plus se soucier des redirections de ports USB ou série.

Je vais faire une vidéo dans les jours qui viennent là dessus avec la manière de faire dans Nodered pour accéder au boîtier puis à l'onduleur.
Voici les premières images:


           

Mon Pi et le convertisseurs sont connectés via un CPL (Courant Porteur en Ligne) à mon réseau filaire.
   

La connexion RJ45 série connectée à l'autre bout du convertisseur
   

Statuts de l'était du petit boîtier

   
jean.pustel@gmail.com likes this post
Jean-Luc
Répondre
#2
(16-07-2022, 05:30 PM)jlm a écrit : Voilà j'ai reçu le petit convertisseur Elfin EE10    RS232 <---> RJ45 Ethernet.



J'ai câblé la bestiole et cela fonctionne parfaitement Shy ****
Maintenant mon onduleur est connecté directement sur Ethernet en filaire. Plus besoin de USB ni de WiFi. :Smiley_20040821172041111:

Même pas besoin de modifier mon logiciel car le boîtier fonctionne avec les mêmes "settings" que la version Wifi (sauf la partie wifi évidemment)
Une solution vraiment élégante sans se ruiner. (22€ chez Amazon, évidemment moins chez Ali)

Du coup on peut mettre le Raspberry dans le salon (ou ailleurs)
ou utiliser une machine virtuelle sans plus se soucier des redirections de ports USB ou série.

Je vais faire une vidéo dans les jours qui viennent là dessus avec la manière de faire dans Nodered pour accéder au boîtier puis à l'onduleur.
Voici les premières images:




Mon Pi et le convertisseurs sont connectés via un CPL (Courant Porteur en Ligne) à mon réseau filaire.


La connexion RJ45 série connectée à l'autre bout du convertisseur


Statuts de l'était du petit boîtier
Bonjour tout le monde , 
super tous ces essais , ça peut être intéressant dans certains cas !.... :)
jlm likes this post
Répondre
#3
ah parfait tu m a convaincu, j en commande de ce pas !!!
Répondre
#4
(16-07-2022, 05:47 PM)jean.pustel@gmail.com a écrit :
(16-07-2022, 05:30 PM)jlm a écrit : Voilà j'ai reçu le petit convertisseur Elfin EE10    RS232 <---> RJ45 Ethernet.



J'ai câblé la bestiole et cela fonctionne parfaitement Shy ****
Maintenant mon onduleur est connecté directement sur Ethernet en filaire. Plus besoin de USB ni de WiFi. :Smiley_20040821172041111:

Même pas besoin de modifier mon logiciel car le boîtier fonctionne avec les mêmes "settings" que la version Wifi (sauf la partie wifi évidemment)
Une solution vraiment élégante sans se ruiner. (22€ chez Amazon, évidemment moins chez Ali)

Du coup on peut mettre le Raspberry dans le salon (ou ailleurs)
ou utiliser une machine virtuelle sans plus se soucier des redirections de ports USB ou série.

Je vais faire une vidéo dans les jours qui viennent là dessus avec la manière de faire dans Nodered pour accéder au boîtier puis à l'onduleur.
Voici les premières images:




Mon Pi et le convertisseurs sont connectés via un CPL (Courant Porteur en Ligne) à mon réseau filaire.


La connexion RJ45 série connectée à l'autre bout du convertisseur


Statuts de l'était du petit boîtier
Bonjour tout le monde , 
super tous ces essais , ça peut être intéressant dans certains cas !.... :)

heuuuuuu , Jean Luc , si tu veut , je peut te donner des conseils pour les câblage ??? :s :D Cool Cool.....?????    
jlm likes this post
Répondre
#5
Il faut reconnaitre que là !... c'est un peu fait à l'arrache !??
Par contre comme çà marche c'est Top !??
jlm likes this post
Répondre
#6
Citation :heuuuuuu , Jean Luc , si tu veut , je peut te donner des conseils pour les câblage ??? [Image: confused.png] [Image: biggrin.png] [Image: cool.png] [Image: cool.png].....?????

Citation :Il faut reconnaitre que là !... c'est un peu fait à l'arrache !??

Merci les gars pour votre manière élégante de me chambrer sur mes compétences en câblage  :D

C'est clairement un câblage de prototypage. Je ne reste pas avec ceci en production.
Si je fais une démo, c'est l'idée. Ce sera plus parlant de voir les fils que de tout mettre dans un boîtier qui cache la beauté des couleurs des brins conducteurs

Mais je reconnais volontiers que ce n'est pas ma tasse de thé. Qui est prêt à m'en confectionner une 20aines Deutch Qualität ?

Ça pourrait être utile par la suite.
Jean-Luc
Répondre
#7
(17-07-2022, 03:15 PM)jlm a écrit :
Citation :heuuuuuu , Jean Luc , si tu veut , je peut te donner des conseils pour les câblage ??? [Image: confused.png] [Image: biggrin.png] [Image: cool.png] [Image: cool.png].....?????

Citation :Il faut reconnaitre que là !... c'est un peu fait à l'arrache !??

Merci les gars pour votre manière élégante de me chambrer sur mes compétences en câblage  :D

C'est clairement un câblage de prototypage. Je ne reste pas avec ceci en production.
Si je fais une démo, c'est l'idée. Ce sera plus parlant de voir les fils que de tout mettre dans un boîtier qui cache la beauté des couleurs des brins conducteurs

Mais je reconnais volontiers que ce n'est pas ma tasse de thé. Qui est prêt à m'en confectionner une 20aines Deutch Qualität ?

Ça pourrait être utile par la suite.
:D :D :D :D :)
Répondre
#8
Comme promis, voici une vidéo faite ce matin pour expliquer en détail comment se servir de ce petit boîtier Elfin EE10
et surtout comment poser des questions à l'onduleur et comment lire et mettre en forme sa réponse.

C'est je pense assez fouillé. Évidemment c'est sous Nodered. Bon il faut se farcir 23 minutes de vidéo. C'est sous forme de tutoriel.


Citation :Si vous souhaitez découvrir Nodered, plongez avec moi dans cette vidéo  Arrow


Et à vos commentaires Blush....



Jean-Luc
Répondre
#9
(18-07-2022, 07:22 PM)jlm a écrit : Comme promis, voici une vidéo faite ce matin pour expliquer en détail comment se servir de ce petit boîtier Elfin EE10
et surtout comment poser des questions à l'onduleur et comment lire et mettre en forme sa réponse.

C'est je pense assez fouillé. Évidemment c'est sous Nodered. Bon il faut se farcir 23 minutes de vidéo. C'est sous forme de tutoriel.


Citation :Si vous souhaitez découvrir Nodered, plongez avec moi dans cette vidéo  Arrow


Et à vos commentaires Blush....

ah ben voilà une bonne démo de discussion machine !...et surtout l'occasion de voir ce que peut faire nodered avec " ses plats tous préparés " excellent ,..merci Jean Luc.. :)

jlm likes this post
Répondre
#10
C'est une jolie manière de décrire ce genre de programmation.
J'aime beaucoup
Jean-Luc
Répondre
#11
Bien reçu ce jour, commandé sur ali express et livré en 11 jours pour 17€ livré avec le support et le connecteur (possibilité bien moins cher si on n'utilise pas le connecteur mais je voulais pas m’embêter).
jean.pustel@gmail.com likes this post
Répondre
#12
Ça speed, le connecteur est juste essentiel pour le prototypage. Alors tu vas le faire fonctionner avant 12 h00 ?
Allez c'est ton défi. Poste nous des photos ou vidéo une fois que cela fonctionne.
Ce sera top ! Good Luck
jean.pustel@gmail.com likes this post
Jean-Luc
Répondre
#13
alors avant midi ca va être compliqué car je suis tributaire de toi  :D
Répondre
#14
Mais qu'est ce que j'ai encore fait moi Angel
jean.pustel@gmail.com likes this post
Jean-Luc
Répondre
#15
(28-07-2022, 05:05 PM)jlm a écrit : Mais qu'est ce que j'ai encore fait moi Angel

rien de mal, me manque juste l'onglet activation Passerelle wifi dans le menu reglage  :P
jean.pustel@gmail.com likes this post
Répondre
#16
bon résultat ca fonctionne également chez moi mais j y ai passé plus de temps (avec l aide de jean luc).
Donc pour tout ceux qui ont pas envie de se grater la tête trop longtemps il faut prendre les fils 1 et 2 (pour la communication vers le boitier) sur la prise rj45 (autrement dit le orange et orange/blanc sur un cable rj45 normalisé de type droit)
tout ceci relié aux bornes 5 et 6 du boitier elfin.
Et si ca communique pas vous inversez les deux fil !!

ah savoir que chaque constructeur en fait a sa tête, par exemple pour dialoguer avec une batterie pylontech us2000c il faut utiliser les fil 3 et 6 du rj45 (vert et vert/blanc).
jlm likes this post
Répondre
#17
Allez gazzzzton on s'est fait plaisir à chercher pourquoi cela ne fonctionnait pas :@ :( :D 
Un plaisir de bosser avec toi !

pour étayer un peu plus ton explication ci-dessus, je me suis fendu d'un schéma ci-dessous Je suis fort en dessin :-/ hein ?

   

PS. Important.
La liaison Smartphoton - Elfin se base sur l'adresse IP, le port et la Socket. La socket est choisie de manière transparente lors de la connexion entre les 2 machines.
Cependant, si vous veniez à arrêter le boîtier et le relancer, il faudra relancer aussi Smartphoton pour qu'ils dialogue à nouveau.
Cela parce que la socket du Elfin aura changée et le Smartphoton ne le sait pas.

Donc bien penser à relancer les 2 de concert si vous redémarrer le petit boitier
jean.pustel@gmail.com and gazzzzton like this post
Jean-Luc
Répondre
#18
J'y ai pensé a faire un schéma mais tu m'a doubler fort heureusement :D
C'est parfait :)
jlm and jean.pustel@gmail.com like this post
Répondre
#19
Bonjour Jean Luc,
Un grand merci pour ce partage de connaissances Cool .
J'ai une question au sujet des deux câbles réseau (celui partant vers l'onduleur et l'autre vers le boîtier CPL), faut il utiliser des câbles droits ou croisés ?
J'ai vu que @Gazzzzton parle de câble droit.
Merci encore  ;)
Jean-Sérien
Répondre
#20
Autant que je me souvienne, c'est un câble droit.
Cependant comme j'ai déjà expliqué à d'autres personnes, je ne me fie pas aux code des couleurs pour être certain de faire juste.
Je prends mon ohmmètre et je vérifie chaque fil d'un coté et de l'autre pour être certain que je connecte la bonne patte sur la bonne patte.

En gros lorsque je coupe le câble réseau, je dénude le fil mettons celui qui devrait être le 1, je le vérifie avec l'ohmmètre , un câble sur la patte 1 (coté doré donc) du rj45 et l'autre câble sur le fil que je viens de dénuder qu'il y a bien continuité.
C'est un brin plus fastidieux du coup que juste les couleurs des brins mais tu es certain de faire juste.
jean.pustel@gmail.com likes this post
Jean-Luc
Répondre
#21
(08-12-2022, 08:19 PM)jlm a écrit : Autant que je me souvienne, c'est un câble droit.
Cependant comme j'ai déjà expliqué à d'autres personnes, je ne me fie pas aux code des couleurs pour être certain de faire juste.
Je prends mon ohmmètre et je vérifie chaque fil d'un coté et de l'autre pour être certain que je connecte la bonne patte sur la bonne patte.

En gros lorsque je coupe le câble réseau, je dénude le fil mettons celui qui devrait être le 1,  je le vérifie avec l'ohmmètre , un câble sur la patte 1 (coté doré donc) du rj45 et l'autre câble sur le fil que je viens de dénuder qu'il y a bien continuité.
C'est un brin plus fastidieux du coup que juste les couleurs des brins mais tu es certain de faire juste.

Bonjour Jean Luc,

Merci pour cette information, je pense que je vais opter pour le ohmmètre  ;) 
Bonne journée à toi.
Jean-Sérien
Répondre
#22
je confirme toujours faire un vérification parce ca m'est arrivé que les chinois livrent des câble croisés a la place des droits alors même qu en les regardant a l oeil nu ils étaient bien en droit.
le chinois est fourbe, il s etait amusé a croisés les couleurs, enfin pire a pas mettre la même couleur de chaque côté des 8 fils (faut le faire hein  :D )
Comme ca c'est drôle mais on a cramé une caméra axis poe a 2000 balles ce jour la, le fournisseur faisait la gueule (fort heureusement c est lui qui nous avait vendu le cable également  Cool )
jlm likes this post
Répondre
#23
Bonsoir, j'ai un onduleur V PLUS Courtois (MPS je crois) : https://www.cdiscount.com/bricolage/elec...43529.html

Est-ce le même branchement ? Je n'ai qu'une prise qui est déjà branchée sur les batteries pour le BMS, mais on dirait bien que c'est aussi là dessus que ce branche le module wifi optionnel du fabricant, donc c'est la seule prise de communication je pense.

Merci,

Camille.
Répondre
#24
normalement il a une usb B
smartPhoton fonctionne avec MPS avec le cable imprimante usb A/B
jlm likes this post
Répondre
#25
Plus le port RS232-RJ45 pour ceux qui en sont lotis
Jean-Luc
Répondre
#26
Bonjour à tous,
j'ai besoin de vos conseils je galère toujours pour faire communiquer mon raspy avec mon onduleur via elfin.
je m’explique, le raspy est en wifi dans la maison brancher en rj45 sur un cpl l’autre cpl relié en rj45 au elfin qui est relié à l’onduleur.
Je communique très bien en wifi avec Smartphoton mais impossible avec l’onduleur,
je ne trouve pas comment récupérer l’IP du elfin pour l’inscrire dans Smartphoton.
Par avance merci de votre aide.
jean.pustel@gmail.com likes this post
Répondre
#27
(12-01-2023, 04:11 PM)STF a écrit : Bonjour à tous,
j'ai besoin de vos conseils je galère toujours pour faire communiquer mon raspy avec mon onduleur via elfin.
je m’explique, le raspy est en wifi dans la maison brancher en rj45 sur un cpl l’autre cpl relié en rj45 au elfin qui est relié à l’onduleur.
Je communique très bien en wifi avec Smartphoton mais impossible avec l’onduleur,
je ne trouve pas comment récupérer l’IP du elfin pour l’inscrire dans Smartphoton.
Par avance merci de votre aide.

Bonjour , pour récupérer une adresse IP d'un matériel , sert toi de l'application Fing.....il détecte tout .. :)
STF likes this post
Répondre
#28
(12-01-2023, 04:11 PM)STF a écrit : Bonjour à tous,
j'ai besoin de vos conseils je galère toujours pour faire communiquer mon raspy avec mon onduleur via elfin.
je m’explique, le raspy est en wifi dans la maison brancher en rj45 sur un cpl l’autre cpl relié en rj45 au elfin qui est relié à l’onduleur.
Je communique très bien en wifi avec Smartphoton mais impossible avec l’onduleur,
je ne trouve pas comment récupérer l’IP du elfin pour l’inscrire dans Smartphoton.
Par avance merci de votre aide.

Peux-tu décrire comment as-tu configuré le Elfin à l'origine, enfin lors de la 1ère connexion a ton réseau ?
Un point important que je n'ai pas renseigné dans la doc en ligne, c'est le No du port pour joindre l'onduleur est par défaut le 7777
"Faudra un jour" que je le rende paramétrable ....
STF likes this post
Jean-Luc
Répondre
#29
oui j'ai bien changer le port 7777

(12-01-2023, 04:11 PM)STF a écrit : Bonjour à tous,
j'ai besoin de vos conseils je galère toujours pour faire communiquer mon raspy avec mon onduleur via elfin.
je m’explique, le raspy est en wifi dans la maison brancher en rj45 sur un cpl l’autre cpl relié en rj45 au elfin qui est relié à l’onduleur.
Je communique très bien en wifi avec Smartphoton mais impossible avec l’onduleur,
je ne trouve pas comment récupérer l’IP du elfin pour l’inscrire dans Smartphoton.
Par avance merci de votre aide.

Merci Jean je test.
jean.pustel@gmail.com likes this post
Répondre
#30
Bonjour messieurs, suite des aventures, toujours impossible de sniffer l’IP du Elfin ce qui est normal puisqu' il est caché derrière le Raspy. l'informaticien de l’entreprise ou je travail me dit qu’il à besoin du code d'accès de Smartphoton pour pouvoir récupérer l’IP du Elfin (Jean-Luc je ne sais ce que tu en pense ?).  Je trouve facilement l’IP du wifi du Raspy et Smartphoton marche très bien, mais impossible de communiquer avec l’onduleur. Merci à tous.
Répondre
#31
Alors j'avais posé une question importante.
Je la repose: Comment as-tu configuré le Elfin pour la 1ère fois ?

Ensuite peux-tu nous faire un croquis à la main de ton réseau, enfin comment sont connectés les divers intervenants. Le router ou/et la box,
les mini-switchs, les boitiers CPL, le Pi, le Elfin
et donc de poster les infos ici.

Pour ce qui est des codes de smartphoton, désolé ce n'est pas possible.
Jean-Luc
Répondre
#32
Photo 
Bonjour Jean-Luc,
toutes mes excuses. Pour la configuration du elfin je l'ai branché directement sur ma box pour le configurer, j'ai suivi à la lettre ta vidéo qui est très clair, sans omettre le changement de port 777.

je suis désolé je n'arrive pas à poster ma photo je vais essayer de l'envoyer en MP ou par mail

et bien non je ne sais pas comment joindre la photo
Répondre
#33
c'est mon plus beau chef-d'œuvre


Pièces jointes Image(s)
   
Répondre
#34
Les cpl sont une solution facilité mais surtout une source d 'ennuis, dans mon métier on a finit par les bannir.
met le cpl au niveau de ta box et non au niveau du Raspberry comme ça il communiquera avec ton réseau et tu pourra le récupérer par la connexion wifi de ton raspberry.
La ça passe par ta carte réseau du Raspberry et donc le rasp ne fait pas le rapprochement avec ton réseau maison.

Et faut que les câbles 230v sur lesquels tu as branché tes cpl soit alimenté par le même réseau 230 (onduleur dans le cas présent) sinon ça marchera pas. dernière chose si ca marche toujours pas, met un des cpl a l envers dans la prise.
jlm likes this post
Répondre
#35
Merci beaucoup pour ton aide Gazzzton,
il n’y à pas de problèmes du côté des CPL ça fonctionne impec.
je ne peux pas déplacer le CPL vers ma box, la ligne elec est différente.
Jean-Luc il me semblait avoir compris que tu avais à peu près la même instal ou je me trompe.
je sèche pour récupérer l’IP du elfin et le mettre dans smartphoton
Répondre
#36
malheureusement va falloir trouver une solution de ce coté la parce que ton wifi du Raspberry est bien sur ton réseau mais le réseau ethernet du Raspberry sur lequel est branché ton elfin par le biais du cpl n'est pas le même ... (pour cette raison que ton informaticien veux accéder au Linux de jean Luc)

la ligne elec est differente c'est a dire, pas le même potentiel ?
Répondre
#37
oui exact

du coup je suis coincé je n'ai aucune solution
Répondre
#38
plusieurs solutions sont possibles:

déplacer la box au niveau du raspberry ou mettre un switch wifi/ethernet esclave au niveau du raspberry sur lequel tu branche ton cpl en ethernet et tu balance en wifi vers ta box (ca reste du bricolage mais ca fonctionnera...)
Répondre
#39
ok très bien merci, je vois ça avec l'informaticien s'il a un peu de matériel à me prêter
Répondre
#40
bien vu Gazzzton. En effet cela ne peut pas fonctionner tel que. Cela voudrait dire que ton Pi fait office de routeur. Il devrait router en effet les paquets qui lui arrivent par la carte wifi vers sa carte ethernet RJ45. Ce qui n'est pas prévu dans son cahier des charges.
Il faut en effet ajouter une CPL au niveau de la box.
De mon coté, à la cave où se trouve divers équipement, je les ai tous branché sur un switch intermédiaire qui lui est relié à mon router (ou la box) via le CPL.
Avec un dessin, on comprend tout de suite mieux :-)
Ah oui un switch c'est moins de 15€. Mais il faut vraiment que ce soit bien relié via le 230V sinon c'est mort.
Jean-Luc
Répondre
#41
Merci à tous pour votre aide je ne manquerai pas de vous tenir au courant. Bonne fin de W
jlm likes this post
Répondre
#42
(10-01-2023, 11:35 AM)bishnoi a écrit : normalement il a une usb B
smartPhoton fonctionne avec MPS avec le cable imprimante usb A/B

Merci, mais je n'ai pas de prise USB sur l'onduleur, uniquement du CAN en RJ45. Faut-il adapter une prise ?

(10-01-2023, 08:12 PM)jlm a écrit : Plus le port RS232-RJ45 pour ceux qui en sont lotis

Merci, quel est le branchement pour ce cas de figure ? J'ai cet adaptateur mais je ne vois aucune donnée sur /dev/ttyUSB0

Merci beaucoup,

Camille.
Répondre
#43
Bonjour à tous,
merci Gazzzton, merci Jean-Luc, je viens de recevoir mon switch wifi ça y est j'arrive à piloter mon onduleur.
j'ai toujours des problèmes de réception de données de consommation,
le projet avance c'est trop bien.
Bon weekend
jlm and gazzzzton like this post
Répondre
#44
Bonsoir, y a-t-il un manuel pour le fonctionnement du EE10A via Ethernet ? Je n'en trouve aucun en ligne. Je suppose qu'en branchant le RJ45 sur l'ordi je reçois une IP par DHCP, seulement rien ne se passe, pas de diode, ni de détection du branchement côté PC (qui fonctionne branché sur d'autres appareils via ce même RJ45). Je suppose que mon EE10A est cramé, mais j'aimerais être sûr que ce fonctionnement n'est pas normal avec quelqu'un qui l'a déjà fait fonctionné. Je venais juste de le recevoir, je ne l'ai jamais fait fonctionner. J'ai eu un problème au premier branchement, j'ai utilisé cette prise, seulement elle est inversée de 1 à 8 elle est de 8 à 1 !!! Je m'en suis aperçu trop tard, j'ai donc envoyé le 5V du Raspberry dans les pins 1 et 2 au lieu de 7 et 8 ! Le Raspberry a redémarré sur le coup, j'ai débranché immédiatement, mais c'est resté branché 1~2 secondes, je crois que ça a endommagé la partie Ethernet du EE10A (opposée à l'alimentation), ce qui expliquerait pourquoi le réseau ne marche plus. En effet après m'en être aperçu j'ai branché avec une autre prise, l'appareil s'allume, mais pas de réseau⋅ Je voulais savoir si c'était bien cassé avant d'en recommander un. Merci.

Camille.
Répondre
#45
Citation :Je suppose qu'en branchant le RJ45 sur l'ordi je reçois une IP par DHCP, seulement rien ne se passe, pas de diode, ni de détection


Je ne pense pas que le port soit cramé. Enfin je suis souvent positif. Il est sensé être protégé via une diode interne.

Par contre il faut brancher le rj45 sur le switch, pas sur le PC. Ça devrait aller mieux après.
En effet le switch va relayer la demande DHCP du Elfin vers ton routeur/Box et recevoir en retour son adresse IP.
Ensuite la rechercher via Fing, ou le router/box.



Citation :Bonsoir, y a-t-il un manuel pour le fonctionnement du EE10A via Ethernet ?


La seule documentation que je n'ai jamais trouvée est celle-ci. Rien d'autre ailleurs.
Jean-Luc
Répondre
#46
Ahhh, merci ! Je croyais que c'était le EE10 qui attribuait une IP au PC, pour accéder à l'interface, et ainsi configurer le réseau, c'est souvent comme ça. Du coup j'en ai acheté un autre, j'en ai 2 :-D

Camille.

Bonsoir à tous, j'ai un problème avec le RS232 sur mon onduleur Courtois.

   

Si je branche le RX-TX-GND du RJ45 sur mon interface ttyUSB0 l'onduleur se met en alerte (led rouge). Parfois l'écran LCD s'éteint, parfois pas, mais les infos LCD sont incohérentes (0V).

   
   

Je reçois quelques octets comprehensible par seconde.

   

Si je ne branche pas le RX (l'onduleur ne reçoit rien du Raspberry), je n'ai pas d'alerte côté onduleur, mais les données demeurent bizarres.

Avez-vous une idée de ce qui ne va pas ?

Merci,

Camille.
Répondre
#47
Citation :Si je branche le RX-TX-GND du RJ45 sur mon interface ttyUSB0 l'onduleur se met en alerte (led rouge). Parfois l'écran LCD s'éteint, parfois pas, mais les infos LCD sont incohérentes (0V).

Je serais curieux de voir comment tu connectes ton port rj45 du Courtois sur ton port USB du Pi.
Attention, le port USB du Pi fourni une tension non négligeable qui peut détruire le port de communication de l'onduleur.
certainement la raison pour laquelle ton onduleur crie. Heureusement ils ont dû protéger le port avec des diodes.
Jean-Luc
Répondre
#48
Bonjour Jean-Luc, merci pour ta réponse. Ma connexion me semble assez standard, la seule différence c'est mon adaptateur qui n'a pas les même numéros de bornes. Le même adaptateur marche pour la console de la batterie maître Pylon. Tu penses que ça peut venir de là ? Le truc bizarre aussi c'est que ça se met en alerte même quand je ne fais que lire et que j'envoie pas de données, mais si je débranche le RX côté onduleur plus de problème.

Voici le branchement (les connecteurs RJ45 sont inversés de 8 à 1) :

   
   

Merci à toi,

Camille.
Répondre
#49
Bonjour à tous,
un petit message pour donner des nouvelles, ça y est j'ai enfin réussi tout fonctionne, merci à tous pour vos conseils, néanmoins j'ai trouvé deux bugs dans le logiciel dans le menu N16 impossible d'utiliser le mode oso tous les autres fonctionnent, ainsi que dans la menu N29 je ne peux pas changer les valeurs, je ne sais pas si ce bug est connu je le fais remonter au cas où.
Encore merci pour tous vos conseils.
Répondre
#50
Bonjour

Peut être que ton onduleur ne fonctionne pas exactement avec les mêmes paramètres que ceux que gèrent smartphoton.

J'ai aussi des critères qui ne fonctionnent pas chez moi parce qu'ils ne sont pas gérés sur mon onduleur comme ceux sur la base desquels le logiciel a été fait.

Cordialement
STF likes this post
Répondre
#51
Une question est-ce que nous onduleurs chinois sont capables de faire de l'injection réseau où est-ce qu'il faut absolument refaire un tableau d'alimentation séparés.
Répondre
#52
Bonsoir, j'ai acheté un autre adaptateur RS232 avec prise DB9 plutôt que le RJ45, j'ai toujours des signaux binaires bizarres, mais un peut différents. L'onduleur se met toujours en alerte si son RX est branché. Avez-vous une idée d'où ça peut venir, pensez-vous que ce soit un protocole différent ?

Merci,

Camille.

   
   
Répondre
#53
Bonsoir

Je vois 3 câbles sur ton montage : TX RX GND VCC Ça fait 4 normalement
Répondre
#54
Que dit ta documentation sur le port série ? Ce n'est pas tant les caractères bizarres qui m'inquiètent mais plutôt que l'onduleur n'apprécie pas la connexion.

Peux tu nous faire un schéma complet de ton câblage, a main levée suffira. Donc de bout en bout. Depuis le Linux jusqu'au RJ45.
Peux-tu nous fournir la documentation technique du port de comm ?

As-tu tenté de changer la vitesse a 4800bds, 9600 bds, 128000 bds.
Qu'il n'y ait que 3 fils me va bien. Le 4 fil serait pour alimenter un Elfin par exemple ou une clé Wifi
Jean-Luc
Répondre
#55
(11-02-2023, 10:43 AM)jlm a écrit : Qu'il n'y ait que 3 fils me va bien. Le 4 fil serait pour alimenter un Elfin par exemple ou une clé Wifi

En effet maintenant que tu le précises
Répondre
#56
Bonsoir Jean-Luc, merci pour ta réponse. Voici le schéma, ainsi que les pins du manuel du DB9 et la prise (12) de l'onduleur. Je n'ai pas mis l'alimentation car non nécessaire, et j'ai pas envie griller l'onduleur à envoyer du jus sans être sûr des pins. Oui j'ai essayé toutes les fréquences de bauds possibles. Ce même DB9 fonctionne avec la console des batteries Pylon par ailleurs. Une idée d'où vient le problème ?

Merci,

Camille.

   
   
   
Répondre
#57
Désolé pour le retard. J'étais bien occupé. Le schéma est au top !
Pour moi tu fais tout juste. J'imagine que tu as croisé le Tx et le Rx sans succès. Pourrais-tu néanmoins me faire une capture d'écran de ce que donne l'appui du bouton "USB Device" sous le menu debug ? Je voudrais voir quel chipset est détecté.
Jamais vu ce convertisseur DB9 avec des LED's.
J'ai bien retenu que "Ce même DB9 fonctionne avec la console des batteries Pylon par ailleurs"
Mais il serait peut être bien de commander pour tester sur Amazon un câble convertisseur connu pour voir si cela vient de là !?
Histoire de mettre toutes les possibilités de notre coté
Jean-Luc
Répondre
#58
Bonsoir Jean-Luc, merci pour ta réponse. Oui des fois quand on est devant l'ordi c'est plus simple de sortir Inkscape que papier+crayon :-)

Qu'entends-tu par croiser Tx/Rx ? Si c'est les inverser oui, mais donne rien, toujours l'alerte mais plus aucune info. À moins que tu veuilles dire de mettre les fils en spirale comme le préconise la norme RJ45 ? Ça non j'ai pas essayé.

Je n'ai pas trouvé le menu de debug dans mon installation, mais voici ce que donne lsusb pour ce périphérique :

Code :
Bus 001 Device 007: ID 067b:23a3 Prolific Technology, Inc. USB-Serial Controller

J'ai lu que récemment il y avait eu quelques bugs dans le noyau de Linux sur ce driver, mais apparemment c'est résolu, je n'ai pas eu le problème décrit par ce bug. J'ai le même problème avec l'autre câble qui n'est pas en DB9 mais en RJ45, ce n'est pas le même driver, mais c'est la même marque :

   

Je ne savais pas que c'était la même marque, j'ai choisi celui avec leds justement pour avoir une indication supplémentaire. Mais je vais le changer pour un truc plus standard, quel modèle connu pour fonctionner me conseilles-tu ?

Merci,

Camille.
Répondre
#59
Si tu peux regarder sur les sujets du forum il y a des sujets là dessus. Mais aten va très bien ou chipset prolific aussi
Jean-Luc
Répondre
#60
(22-02-2023, 01:21 AM)jlm a écrit : Si tu peux regarder sur les sujets du forum il y a des sujets là dessus. Mais aten va très bien ou chipset prolific aussi

Bonsoir, merci. D'accord, je vais regarder, mais déjà c'est un Prolific celui-là donc… Je vais essayer aten alors.

Camille.
Répondre
#61
Des que tu l'as, fais nous une capture ecran avec le résultat de l'appui du bouton usb device dans le menu debug ainsi que ce que l'on voit sur les sélections de ports usb dans le menu système
Jean-Luc
Répondre
#62
J'en ai un neuf, bien détecté mais il n'a jamais fonctionné et un autre qui a fonctionné que 4 mois.

Marque a bannir, je pense...

(22-02-2023, 10:33 PM)mammique a écrit :
(22-02-2023, 01:21 AM)jlm a écrit : Si tu peux regarder sur les sujets du forum il y a des sujets là dessus. Mais aten va très bien ou chipset prolific aussi

Bonsoir, merci. D'accord, je vais regarder, mais déjà c'est un Prolific celui-là donc… Je vais essayer aten alors.

Camille.
Répondre
#63
Bonjour à tous,

Je me décide enfin a connecter le Elfin sur mon onduleur, j'ai deux prises... une USB et une RJ45, l'onduleur est noté comme ayant une prise RS232 .. j'imagine donc que les deux sont RS232.
Mais voila .. impossible d'avoir le PÏNOUT de cette sortie onduleur RJ45, j'ai bien repéré quelques voltages au voltmètre .. mais je ne voudrais pas faire de connerie.

Quelqu'un a t'il déjà connecté cet onduleur : (Isolar SML II 5.5kW)

   


Je pense que les onduleurs chinois n'ont pas tous le même câblage au niveau de cette prise RS232 de communication. Surtout qu'il est normalement possible d'y raccorder un boitier Wifi qui est alors alimenté par cette prise RJ45, j'aimerais également alimenter le ELFIN via cette même prise, sans transfo externe.
Répondre
#64
Bonjour, ton onduleur ressemble en tout point visuellement aux nôtres.
Donc RJ45 pin 1&2 Tx-Rx (ou inversement), 4 Vcc et 8 Gnd.
Il doit donc pouvoir s'alimenter via la 4 et la 8 donc. C'est ce que nous faisons.
Le Elfin doit s'allumer si ok. Si pas de data's en transfert, croiser le 1 et 2
Honu likes this post
Jean-Luc
Répondre
#65
(23-02-2023, 04:43 PM)jlm a écrit : Bonjour, ton onduleur ressemble en tout point visuellement aux nôtres.
Donc RJ45 pin 1&2 Tx-Rx (ou inversement), 4 Vcc et 8 Gnd.
Il doit donc pouvoir s'alimenter via la 4 et la 8 donc. C'est ce que nous faisons.
Le Elfin doit s'allumer si ok. Si pas de data's en transfert, croiser le 1 et 2

Salut Jlm, 

Merci de ta réponse, c'est ce que j'ai fait, le Elfin s'allume ... vert 0.3s On / 0.3s Off
=> J'utilise un EW10A, Le modele RS232 => Wifi

Il faudrait le passer en mode "SmartLink" afin qu'il fonctionne en mode AP, puis on s'y connect via un client wifi afin de configurer le Elfin via l'interfazce web : http://10.10.100.254 pour y mettre les informations concernant notre routeur Wifi.

Mais voila ... j'ai beau connecter le fil nReload sur le GND ... rien  ne se passe .. quelqu'un utilise t'il la version Wifi (EW10 ou EW10A) ?

Voici la table pour le EW10/EW10A ainsi que la note explicitant le fonctionnement du contact Reload
       
Répondre
#66
Pas certain de te suivre.
As tu déjà configuré ce elfin ?
Par défaut il se met en mode access point et donc tu dois le voir dans les ssid wifi
Honu likes this post
Jean-Luc
Répondre
#67
(23-02-2023, 07:03 PM)jlm a écrit : Pas certain de te suivre.
As tu déjà configuré ce elfin ?
Par défaut il se met en mode access point et donc tu dois le voir dans les ssid wifi

Non justement, je ne l'ai jamais configuré, mais aucun AP ne s'affiche, mon PC portable ainsi que mon téléphone Android ne voient aucun nouvel AP.
Raison pour laquelle je cherche a le passer en mode AP (Reload durant un laps de temps entre 0.2 et 1.5s => pas de changement du clignotement.

Je me demande si mon exemplaire n'a pas un problème ... je vais en commander un autre.

Pour info : https://fr.aliexpress.com/item/1005002431213175.html
11€85 chez ce vendeur
Répondre
#68
regarde si ton réseau est sur le wifi 2.4Ghz ou 5Ghz ? le Eflin est sur 2Ghz ! Donc vérifier la fréquence de ton wifi sur ton téléphone pour chercher le Elfin
Honu likes this post
Jean-Luc
Répondre
#69
(23-02-2023, 11:22 PM)jlm a écrit : regarde si ton réseau est sur le wifi 2.4Ghz ou 5Ghz ? le Eflin est sur 2Ghz !  Donc vérifier la fréquence de ton wifi sur ton téléphone pour chercher le Elfin

J'ai les deux réseaux, l'AP du Elfin est effectivement sur le 2Ghz, je devrais le voir sans soucis mais ce n'est pas le cas.
En fait j'ai branché un autre Elfin (EW11A - rs485 Wifi) et il passe instantanément en mode smartlink quand je presse le pin 4 (Reload), il y a donc un soucis avec le mon exemplaire du EW10A, j'en ai commandé un autre, a voir dans un mois.. :D
jlm likes this post
Répondre
#70
okay. see you
Jean-Luc
Répondre
#71
J'ai trouvé le problème. J'ai pensé acheter l'adaptateur wifi officiel de l'onduleur (marque Courtois), pour tester et au moins savoir s'il était possible de dialoguer avec l'appareil d'une manière ou d'une autre, bien que je veuille du filaire au final. Je m’aperçois que sur la page de l'adapteur wifi il est indiqué qu'on ne peut pas le brancher en même temps que l'écran LCD au risque de casser l'onduleur ! Alors j'ai essayé à nouveau le RS232 en débranchant l'écran, et là ça marche ! Donc je peux avoir les donnée sur le Raspberry, mais pas en même temps sur l'écran… C'est ennuyeux, vous trouvez ça normal ?

Merci,

Camille.
jlm likes this post
Répondre
#72
Magnifique idée que de débrancher cet écran. Exclamation
Du coup oui, tout se tient. C'est lui qui prenait le port de communication, voir l'alimentation de la carte série.
Enfin un truc comme ça.

C'est un très bon retour d'expérience. Merci. :Smiley_2004082117204183:
mammique likes this post
Jean-Luc
Répondre
#73
Bonjour,

Problème réglé pour moi, j'ai reçu un nouvel EW10A et tout fonctionne du premier coup, l'ancien est donc foutu...
Répondre
#74
argh, le temps que l'on peut y passer sur ces petites choses.
Content que cela fonctionne bien !
Jean-Luc
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)
[-]
Synthèse
Please login or register to use this functionality.

[-]
discussions récentes
Configuration Elfin-Rj45 avec...
Voir ma réponse sur ce sujet à...jlm — 11:06 AM
Intégration growatt spf 5000ES
Bonjour aston68, Alors tu vas...jlm — 11:03 AM
Configuration Elfin-Rj45 avec...
Bonjour, j'ai fait l'acquisiti...aston68 — 10:23 AM
[error] [function:Tri Q...] T...
Oui, il me faut plus d'aide,...Sylvain — 09:59 AM
Intégration growatt spf 5000ES
Bonsoir, j'ai installé smartph...aston68 — 11:09 PM
Simple EVSE DIY Wallbox
bravo, très beau câblage et fi...bishnoi — 10:54 PM
Smartphoton Config
Impressionnant. Il ne doit pas...jlm — 07:59 PM
Problème installation smartph...
Tu as l'air d'être bon du coté...NOLAK — 07:47 PM
[error] [function:Tri Q...] T...
Oui, il me faut plus d'aide, a...NOLAK — 07:23 PM
Smartphoton Config
Bonjour les amis, aujourd'h...NOLAK — 07:07 PM
[error] [function:Tri Q...] T...
ok des batteries en série Au ...Sylvain — 06:59 PM

[-]
Rechercher








(Advanced Search)

[-]
Who's Online
There are currently 34 online users. [Complete List]
» 2 Member(s) | 32 Guest(s)
AvatarAvatar

[-]
goals
85.1% of the way to our goal of 6,000 posts!
Only 892 posts left to go!

[-]
Statistics
» Members: 519
» Latest member: dfremond
» Forum threads: 565
» Forum posts: 5,107

Full Statistics

>