Bonjour Mr. le visiteur, si vous lisez ceci, cela signifie que vous n'êtes pas enregistré. Cliquez ici pour vous inscrire en quelques étapes simples, vous pourrez profiter de toutes les fonctionnalités de notre Forum. Vous pourrez évidemment nous faire partager vos connaissances avec nous ! et voir les images ou vidéos postées



Note de ce sujet :
  • Moyenne : 1 (1 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Probléme communication Elfin et Home-Assistant
#1
Bonjour,

Après une journée à avoir fait des essais et à avoir parcouru ce forum, j'ai décidé de demander de l'aide.

Je vais essayer de détailler au maximum mon problème tout en décrivant toutes les actions que j'ai déjà effectuées pour tenter de les résoudre, espérant que cela puisse servir à d'autres personnes.

Pour commencer, voici une rapide description de mon installation :

Onduleur hybride WKS Evo MAX II 10kVA 48V
2 Batteries Lithium Pylontech US5000 +100 - 4.8kWh
Home Assistant qui tourne sur une machine virtuelle de ma Freebox Delta
2 Elfins EW10 pour connecter mon onduleur et mes batteries.
Commençons par le branchement des Elfins :

J'ai suivi les indications de branchement que j'ai trouvées dans la documentation de mon onduleur :
[Image: Capture-d-cran-2024-04-20-162623.png]
De même pour l'Elfin, et voici le résultat :

[Image: PXL-20240420-140850855.jpg]


C'est un peu désordonné, mais tant que ce n'est pas fonctionnel, je garde les Wago !

Passons à la configuration de l'Elfin ; j'ai scrupuleusement suivi la documentation que l'on peut trouver ici. Voici des captures d'écran :

[Image: Capture-d-cran-2024-04-20-160522.png]
[Image: Capture-d-cran-2024-04-20-160455.png]
[Image: Capture-d-cran-2024-04-20-160438.png]

Passons maintenant à Home Assistant, pour lequel j'ai également suivi la documentation disponible sur le Github. Voici une capture d'écran de ma configuration :

[Image: Capture-d-cran-2024-04-20-160623.png]

Et voici une copie des LOGS :

[Image: Capture-d-cran-2024-04-20-161158.png]
[Image: Capture-d-cran-2024-04-20-161210.png]


Donc, après avoir décrit mon installation, voici mon problème : la communication ne semble pas passer entre mes Elfins et l'onduleur ainsi que la batterie.

J'ai refait mon montage avec 3 câbles réseau différents, j'ai essayé 3 alimentations différentes pour mes Elfins (deux 12V et une 5V). J'ai essayé de changer certains paramètres du port COM des Elfins sans succès.

Voilà pour ma situation. Si quelqu'un a une idée d'où pourrait venir le problème, je suis plus qu'intéressé !

Folzo -
Répondre
#2
Salut,

Si c'est du elfin dans la configuration du module il faut écrire dans type "ip" et non "serial"

Pour onduleur
Code :
- chemin: 192.168.1.16:7777
  type: ip
  onduleur: voltronic
  battTension: 48
  multionduleur: true

Pour les batterie (aussi ajouter le port)
Code :
- chemin: 192.168.1.172:7777
  type: ip
  batterie: pylontech
Répondre
#3
Merci beaucoup pour l'info, j'avais essayé de mètre efli dans "type", mais je n'avais pas pensé a tout simplement IP. Si jamais je n'ai pas trouvé cette info dans la description.

J'ai maintenant des paquets qui sont transmis mais je n'ai pas de retour d'information de la part de mon onduleur :


[Image: Capture-d-cran-2024-04-20-171521.png]

Cela semble être un défaut de câblage ou mon onduleur qui ne serait pas compatible ?

- Folzo -
Répondre
#4
Et coté batterie ?

Tu peux afficher a nouveau tes logs ?
Vérifier aussi dans intégrations mqtt, si tu as les appareils qui remontent
Répondre
#5
Pour la configuration, tu peux t'aider du configurateur ici

https://domosimple.eu/forum/thread-695.html.
Répondre
#6
Coté batterie, c'est fonctionnel !!! 

J'avais oublié de mettre le port, une fois corrigé, les informations sont bien remontées et le MQTT est bien fonctionnel, j'ai le retour des batteries sur mon tableau de bord :

[Image: Capture-d-cran-2024-04-20-173715.png]

Voici les logs :

[Image: Capture-d-cran-2024-04-20-173544.png]
jlm aime ce post
Répondre
#7
Déjà une bonne chose, donc côté onduleur.
- soit c'est un problème de port ou d'ip
- soit de config Elfin
- soit de branchement.

Côté Smartphoton ça a l'air correcte
Répondre
#8
Voilà j'ai pris le temps de recabler plus proprement mes câbles RJ45 et j'ai une amélioration :

[Image: Capture-d-cran-2024-04-20-185050.png]

Cependant, ce sont les données reçu qui ne sont pas interprétables :

[Image: Capture-d-cran-2024-04-20-185120.png]

Merci encore pour l'aide, en espérant que cela serve à d'autres personnes !
Répondre
#9
Je ne comprends pas très bien ta config.
Sur ton dernier screen tu montres un Elfin en
192.168.1.173
Cette IP tu l'as mis pour ton brokers mqtt et tu avais mis en Elfin onduleur
192.168.1.16

Tu n'aurais pas un petit mélange d'ip ?

Logiquement le wks devrait être compatible a moins qu'ils ont changés le protocole de communication
Répondre
#10
(20-04-2024, 05:19 PM)Folzo a écrit : Merci beaucoup pour l'info, j'avais essayé de mètre efli dans "type", mais je n'avais pas pensé a tout simplement IP. Si jamais je n'ai pas trouvé cette info dans la description.

J'ai maintenant des paquets qui sont transmis mais je n'ai pas de retour d'information de la part de mon onduleur :


[Image: Capture-d-cran-2024-04-20-171521.png]

Cela semble être un défaut de câblage ou mon onduleur qui ne serait pas compatible ?

- Folzo -

Je me répond tout seul, la config est bien expliqué dans la page "documentation" du module Smartphoton :

[Image: Capture-d-cran-2024-04-20-185904.jpg]

(20-04-2024, 07:04 PM)NOLAK a écrit : Je ne comprends pas très bien ta config.
Sur ton dernier screen tu montres un Elfin en
192.168.1.173
Cette IP tu l'as mis pour ton brokers mqtt et tu avais mis en Elfin onduleur
192.168.1.16

Tu n'aurais pas un petit mélange d'ip ?

Logiquement le wks devrait être compatible a moins qu'ils ont changés le protocole de communication

mon Elfin pour l'onduleur est bien en 192.168.1.16

[Image: Capture-d-cran-2024-04-20-191025.png]

Je ne sais pas d'où viens l'adresse l'IP du serveur TCP et effectivement elle ne s'affiche pas avec le delfi de la batterie :
[Image: Capture-d-cran-2024-04-20-192617.png]

En comparant les deux screenshot, il y a une différence dans me State TCP-server, un et "server created" l'autre est "connnected"
Répondre
#11
permuter RX TX
relancer Smartphoton
relancer HA
il faut que l'IP ...173 apparaisse en bas
Répondre
#12
(20-04-2024, 09:23 PM)bishnoi a écrit : permuter RX TX
relancer Smartphoton
relancer HA
il faut que l'IP ...173 apparaisse en bas

J'ai testé ces solutions, mais sans résultat.
J'ai échanger mes 2 Elfis, sans résultat je n'ai pas réussi a avoir une communication avec l'onduleur.
J'ai désinstallé smartphoton et MQTT et tout réinstaller; Maintenant les batteries sont elles aussi plus connectées...

Voici les logs que j'ai après ma réinstallation :
[Image: Capture-d-cran-2024-04-20-225734.png]
Ce qui est écrit en orange peut-il avoir un impact ?
[Image: Capture-d-cran-2024-04-20-230746.png]

Sinon voici les config de mes 2 elfis :
[Image: Capture-d-cran-2024-04-20-230432.png]
[Image: Capture-d-cran-2024-04-20-230550.png][Image: Capture-d-cran-2024-04-20-230607.png]
[Image: Capture-d-cran-2024-04-20-230640.png]

Bref je pense que je suis a cours de solution et que si je continu ce soir je vais faire plus de mal que de bien. En tout cas merci pour votre aide !
Répondre
#13
poste ta config yaml de smartphoton stp
Répondre
#14
(21-04-2024, 01:42 AM)bishnoi a écrit : poste ta config yaml de smartphoton stp

Bien sur, la voici :


Code :
listonduleur:
  - chemin: 192.168.1.16:7777
    type: ip
    onduleur: voltronic
    multionduleur: true
    battTension: 48
listbatterie:
  - chemin: 192.168.1.172:7774
    type: ip
    batterie: pylontech
mqtt:
  mqttadresse: 192.168.1.173
  mqttport: "1883"
  mqttuser: folzo
  mqttpass: toto
nameEntities:
  nameOnduleur: Onduleur
  namePV: PV Puissance (Watt)
  namePV2: PV2 Puissance (Watt)
  nameBatt_charge: Batt Charge (Watt)
  nameBatt_batt_decharge: Batt deharge (Watt)
  nameBatt_batt_chargedecharge: Batt Charge et Decharge (watt)
  nameConso_maison: Conso Maison (Watt)
  nameGridTension: Grid Tension (Volt)
  nameBattTensiont: Batterie Voltage (Volt)
  namePvTensiont: PV Voltage (Volt)
  namePv2Tensiont: PV2 Voltage (Volt)
  nameOnduleurTension: Onduleur Tension (Volt)
  nameDataFrequency: Data Frequency (Hz)
  nameOnduleurFrequency: Onduleur-Frequency (Hz)
  namePvIntensite: Pv Intensite (Amp)
  namePv2Intensite: Pv2 Intensite (Amp)
  nameBattChargeIntensite: Batt Charge Intensite (Amp)
  nameBattDechargeIntensite: Batt Decharge Intensite (Amp)
  nameBattCapacite: Batterie Capacité
  nameMode: Mode Solaire
  nameTemp: Temperature (°)
  nameParam01: Priorité alimentation
  nameParam02: Courant de charge total
  nameParam05: Type de batterie
  nameParam11: Courant de charge EDF
  nameParam12: Tension passage edf
  nameParam13: Tension retour batterie
  nameParam16: Priorité charge batterie
  nameParam26: Tension de charge en vrac
  nameParam27: Tension de charge flottante
  nameParam29: Basse tension coupure DC
ssl: false
certfile: fullchain.pem
keyfile: privkey.pem
Répondre
#15
Pour moi côté config Elfin et Smartphoton c'est ok.
Pour l'avertissement en orange c'est normal et les erreurs serial aussi.
Il faudrait regarder si tu vois quelque choses sur mqtt explorer.
Répondre
#16
Aurais tu un tuto pour installer mqtt explorer ?

Je bloque lorsqu'il faut rentrer le login MQTT :

[Image: Capture-d-cran-2024-04-21-142823.png]
Répondre
#17
Alors, appuye sur le bouton + pour créer un nouvelle connexion
Ensuite entre l'adresse IP de ton Home Assistant et l'utilisateur / mot de passe avec le port 1883
Comme montré sur ma capture

   
Jean-Luc
Répondre
#18
Bonjour, je relance ce sujet après une semaine de vancance.

Pour bien faire, je suis reparti d'une base propre.
J'ai désinstaller MQTT et SmartPhoton de HA. J'ai redémarré celui-ci et réinstaller chacune d'eux en suivant le tuto.


Voici pour rappel les configurations des Elfis : l'adresse finissant par 16 est l'Elfi de l'onduleur et celui finissant par 172 est l'Elfi des Pylontech :

[Image: Capture-d-cran-2024-04-28-121100.png]

ensuite, voici la config de smartphoton :

 [Image: Capture-d-cran-2024-04-28-121204.png]

Voici les LOGS une fois smartPhoton lancé :

[Image: Capture-d-cran-2024-04-28-121223.png]

Etonnamment ce coup ci, je n'ai rien qui s'affiche dans MQTT, j'ai peut être fait une erreur en supprimant les modules avant de désinstaller MQTT :

[Image: Capture-d-cran-2024-04-28-105129.png]

Et voici les informations que j'arrive a voir avec MQTT Explorer :

[Image: Capture-d-cran-2024-04-28-123325.png]

Voilà, malgré une mâtiné passé a réinstaller et a revérifier mon installation, je n'arrive toujours pas à faire fonctionner SmartPhoton. Je reviens encore une fois vers vous pour demander de l'aide. Merci.

- Folzo -
Répondre
#19
Petite mise à jour. Sans rien touché, les batteries sont apparues toute seule sans MQTT Explorer, et pour celles-ci les données sont bien remontés.

[Image: Capture-d-cran-2024-04-28-145018.png]

Par contre je n'ai toujours aucune entrée dans l'application MQTT :

[Image: Capture-d-cran-2024-04-28-145234.png]
Répondre
#20
intégration MQTT: as-tu bien configuré dans la case courtier l'ip de HA ?
Répondre
#21
Peux-tu arrêter le module smartphoton.
Ensuite aller dans MQTT
Sélectionner les Pylontech et toutes les supprimer et ensuite relancer le module ?!
Vérifie bien qu'il n'en reste plus de traces.
Sortir de MQTTexplorer et y retourner pour voir ce qu'il en est.


   
   
Jean-Luc
Répondre
#22
Je suis pas sur de bien comprendre ce que tu entend par "case courtier". 
Si jamais voici la config de SmartPhoton et de MQTT, l'adresse IP de de mon home assistant est bien 192.168.1.173 :

[Image: Capture-d-cran-2024-04-28-181730.png]

[Image: Capture-d-cran-2024-04-28-181758.png]

Je rajoute aussi les logs de MQTT que je trouve assez bizarre :

[Image: Capture-d-cran-2024-04-28-182219.png]
Répondre
#23
Refait la configuration de ton intégration mqtt a mon avis le problème est la.

Paramètres=> appareils et services => mqtt => configurer et reconfigurer mqtt. Juste vérifier si c'est bon.
bishnoi aime ce post
Répondre
#24
(28-04-2024, 08:19 PM)NOLAK a écrit : Refait la configuration de ton intégration mqtt a mon avis le problème est la.

Paramètres=> appareils et services => mqtt => configurer et reconfigurer mqtt. Juste vérifier si c'est bon.

Tout me semble bon :

[Image: Capture-d-cran-2024-04-28-211321.png]

Entre temps, sans que je change quelque chose, l'onduleur est apparu dans le MQTT :

[Image: Capture-d-cran-2024-04-28-211508.png]

Par contre pour celui-ci toujours aucune valeur ne remonte :

[Image: Capture-d-cran-2024-04-28-211635.png]

(28-04-2024, 06:18 PM)jlm a écrit : Peux-tu arrêter le module smartphoton.
Ensuite aller dans MQTT
Sélectionner les Pylontech et toutes les supprimer et ensuite relancer le module ?!
Vérifie bien qu'il n'en reste plus de traces.
Sortir de MQTTexplorer et y retourner pour voir ce qu'il en est.



Mes Pylontech ne s'affichent plus dans le MQTT depuis que je les ai déjà supprimés une fois, alors que j'ai le retour d'information par MQTT Explorer. À quel moment SmartPhoton crée-t-il ces appareils dans MQTT précisément? Est-ce au démarrage de celui-ci?

Par contre, je suis curieux de savoir comment nous pouvons vérifier qu'il n'y a plus de traces ?
Répondre
#25
De toute façon ça refait les capteurs régulièrement, mais la clairement il ne trouve pas les valeurs de ton onduleur.
Tout le reste fonctionne.
Donc pour moi cela vient de la liaison ha Elfin ou Elfin onduleur.
Pour être sûr du coup tu peux déjà essayer :
- changer l'ip du Elfin.
- Tu peux aussi d'essayer d'inverser les deux Elfin (faudra refaire la config)

Si cela fonctionne avec tes pylontech sur les deux Elfin. Tu peux te tourné vers ton câble Elfin onduleur.
Répondre
#26
permuter PIN 1 et 2 coté onduleur (RT TX) ?
Répondre
#27
Petit retour ce soir, les Pylontech se sont bien ajoutées toutes seules entre hier soir et ce matin, et j'ai bien une remontée d'informations.

[Image: Capture-d-cran-2024-04-29-195403.png]

Comme l'a mentionné NOLAK, j'en déduis que le problème de retour d'informations vient de ma liaison HA Elfin ou de l'onduleur Elfin.

Je vais déjà tester de permuter les PIN 1 et 2 côté onduleur et attendre s'il y a des remontées pendant la nuit. Sinon, demain je testerai de changer l'IP de l'Elfin ou encore changer mes câbles réseau côté onduleur.

Merci encore une fois pour vos conseils et votre aide !
Répondre
#28
Alors les remontées sont pratiquement instantané, grand max 5min.
Je l'impression que l'on tourne en rond avec ton problème XD
Peut tu nous rappeler ton onduleur ?
Répondre
#29
(29-04-2024, 08:19 PM)NOLAK a écrit : Alors les remontées sont pratiquement instantané, grand max 5min.
Je l'impression que l'on tourne en rond avec ton problème XD
Peut tu nous rappeler ton onduleur ?

Voici mon onduleur :

Onduleur hybride WKS Evo MAX II 10kVA 48V
Répondre
#30
Es que tu as moyen de passer en Serial directement sans le Elfin ?
Répondre
#31
Je vous fais une petite mise à jour pour vous présenter mes tests de cette semaine visant à établir la communication entre mon onduleur et SmartPhopton.

Le problème que je rencontre est l'absence de retour d'information côté onduleur, se traduisant par l'absence de réception de tout octet du côté de l'ELFIN :
[Image: Capture-d-cran-2024-05-03-185443.png]
Et donc, aucune valeur n'est remontée dans MQTT :
[Image: Capture-d-cran-2024-05-03-170304.png]

Voici les différents tests que j'ai effectués pour comprendre et résoudre ce dysfonctionnement :
  • Premier test : Échange d'ELFIN entre celui de l'onduleur et celui des Pylontech.
Résultat : La communication avec l'onduleur présente les mêmes symptômes, tandis que la communication avec les Pylontech fonctionne avec l'autre ELFIN. J'en déduis que le problème ne vient pas de l'ELFIN (matériel).
  • Deuxième test : Passage aux adresses IP fixes sans DHCP. J'ai reconfiguré chaque ELFIN avec son adresse IP fixe et son masque de sous-réseau.
[Image: Capture-d-cran-2024-05-03-191854.png]
Résultat : Aucun changement de comportement. La communication avec les Pylontech reste fonctionnelle et les batteries apparaissent rapidement dans MQTT. Pour l'onduleur, les mêmes symptômes persistent. Le problème ne vient pas d'une mauvaise configuration réseau.
  • Troisième test : Changement des câbles réseau reliant l'onduleur à l'ELFIN. J'ai essayé avec 3 câbles réseau différents, dont un que j'ai moi-même serti, en utilisant seulement les fils nécessaires : 1, 2 et 8 pour l'onduleur et 5, 6, 7 et 8 pour l'ELFIN.
Résultat : Aucune modification de comportement.
  • Quatrième test : Inversion des fils Rx et Tx entre l'onduleur et l'ELFIN.
Résultat : Aucun changement. Je n'ai toujours pas de retour de "bytes" de l'onduleur.


Pour répondre à Nolak, je n'ai malheureusement pas de câble assez long pour connecter mon onduleur en filaire à ma Freebox (qui héberge Home Assistant).


Les prochaines options que j'ai en tête sont d'essayer d'autres câbles que les 1 et 2 pour le Tx et le Rx de l'onduleur. Même si la documentation est formelle.

Une autre option consiste a jouer avec les paramètres "serial port settings" de l'Elfin onduleur. Peut être que mon onduleur à une particularité et que le baud rate est peut être diffèrent. 
[Image: Capture-d-cran-2024-05-03-191156.png]

Si vous avez d'autre idées je suis preneur ! Merci pour votre temps.
Répondre
#32
la première chose a faire comme t as suggéré romain serait de tester en serial direct sans passer par le elfin, ca éliminerait pas mal de pannes possibles.
NOLAK aime ce post
Répondre
#33
(03-05-2024, 07:58 PM)gazzzzton a écrit : la première chose a faire comme t as suggéré romain serait de tester en serial direct sans passer par le elfin, ca éliminerait pas mal de pannes possibles.

Je vais essayé de récupérer un câble USB de 10m au boulot demain. Pouvez me guider vers un tuto indiquant la connexion filaire ?

Sinon en regardant le câble fourni avec l'onduleur, j'ai vu qu'il y avait 4 fils :
[Image: PXL-20240503-185213473.jpg]
on le voit pas beaucoup sur la mais sur la position 4 il y a un fil noire. 

Sur la DOC ce fil est présenté comme NC.
[Image: Capture-d-cran-2024-04-20-162623.png]

Quelqu'un aurais t'il une idée a quoi pourrait-il servir ?
Répondre
#34
Logiquement tu as besoin que de 3 fils. Le fils noir était branché ?

Tu as pas moyen de tester tes câble avec un logiciel comme watchpower ?
Répondre
#35
logiquement ca sert a l alimentations des dongle usb qu ils vendent généralement pour communiquer avec leur cloud chinois donc si tu l utilise faut le couper sous peine de griller la carte de com de l onduleur sur certains modèles.
Répondre
#36
(04-05-2024, 10:15 AM)gazzzzton a écrit : logiquement ca sert a l alimentations des dongle usb qu ils vendent généralement pour communiquer avec leur cloud chinois donc si tu l utilise faut le couper sous peine de griller la carte de com de l onduleur sur certains modèles.

Donc si je comprend bien, si j'utilise cet adaptateur, je risque de le griller, ou pire ma prise USB ? Pour l'utiliser, je devrai dénuder le câble et couper le fil noir ?

[Image: PXL-20240504-180936486.jpg]

(04-05-2024, 07:27 AM)NOLAK a écrit : Logiquement tu as besoin que de 3 fils. Le fils noir était branché ?

Tu as pas moyen de tester tes câble avec un logiciel comme watchpower ?

Le câble fourni est un câble RJ45 -> port série. Du coup aucune idée d'ou va ce fil noir...

Pour WatchPower, je crois que ça va être la prochaine étape tester avec mon portable.
Aurais tu un lien de téléchargement et un petit tuto pour ce logiciel? Je n'avais pas réussi à trouver la bonne version quand j'avais reçu mon onduleur.
Répondre
#37
Bonsoir,

Tu peux le télécharger ici: 

https://domosimple.eu/wp-content/uploads...ux-Mac.zip
Folzo aime ce post
Jean-Luc
Répondre
#38
Il faut regarder sur le forum il y a des explications comment brancher l'onduleur.
Folzo aime ce post
Répondre
#39
pin 4 c'est +12V en général pour leur d'ongle wifi.
sans le couper, j'ai cramé l'ATEN usb !
Folzo aime ce post
Répondre
#40
Wink 
(05-05-2024, 07:57 PM)bishnoi a écrit : pin 4 c'est +12V en général pour leur d'ongle wifi.
sans le couper, j'ai cramé l'ATEN usb !

Bonjour,

Je confirme que le pin 4 est bien du 12v, je l'ai utilisé pour connecter l'ELFIN est celui-ci est bien alimenté. J'ai donc coupé le fil noir pour pouvoir connecter le câble fourni avec l'onduleur.

J'ai donc installer WatchPower sur mon laptop, connecter le câble RJ45 - port série avec mon adaptateur USB, et rien. Toujours le même symptôme. Aucun retour d'information de la part de l'onduleur. :

[Image: Capture-d-cran-2024-05-09-101701.png]

Je commence à croire que le problème vient de mon onduleur...

J'aurais un peu plus de temps ce weekend, je compte bien résoudre ce problème! (je suis têtu Smile )

Merci encore une fois pour votre lecture et vos conseils.

- Folzo -
NOLAK aime ce post
Répondre
#41
Tu as raison d'être têtu, il faut persévérer et aller au bout des choses.
Moi j'ai eu des soucis avec l'adapter USB db9 qui était neuf n'hésite pas a essayé d'autres marques.
Ça fonctionnait avec les pylontech mais pas avec onduleur ou le contraire.

J'ai pris une autre marque et la magie. Je vais essayer de retrouver. Mais la marque est sur le forum
Folzo aime ce post
Répondre
#42
Je ne vois juste pas le fait que tu aies sélectionné le port Com6, je ne me rappelle plus si cela se fait tout seul sur watchpower ?
Jean-Luc
Répondre
#43
Bonjour à tous. Il y a bien longtemps que je ne suis venu sur votre beau forum !
Il y a eu bien d'autres occupations que l'Onduleur, et pour cause: Tout marchait bien.
Mais, le solaire c'est addictif, j'en ai voulu plus.
J'ai donc ajouté qq PV puis j'ai changé l'onduleur de 3kW pour un de 5.6Kw, je croyais que tout allait suivre...
L'ancien onduleur était relié à l'informatique par une Elfin EW10.
Je l'ai donc utilisé dans la même config avec le nouveau.

ET COMME VOUS je n'ai plus de communication, au point que je soupçonnais, comme vous l'onduleur.
Comme vous je me suis armé de patience, jusqu'à découvrir qu'il y a plusieurs ELFIN:
EW10 qui communique en RS232
EW11 qui communique en RS485

J'ai donc remisé la EW10 pour la remplacer par une EW11...

Mais l'onduleur ne voulait toujours pas causer !

Pour lever le doute j'ai utilisé le logiciel "Packet_Sender-v8.0.9-x86_64.AppImage"
C'est gratuit et c'est un vrai couteau suisse de la communication.

Donc la ELFIN causait bien et l'onduleur aussi... Mais pas à la même vitesse ni avec le même protocole que l'ancien onduleur, comme chez vous WatchPower est muet.

Je suis passé d'un MF-OME-UM 3kVA à un SMX-II-5.6KP-Wifi.
Je vais essayer d'en dire un peu plus sur son côté WiFi... Encore une belle me**e !
À bientôt.
jlm aime ce post
Tout le monde voit quand j'ai bu, personne quand j'ai soif.
Répondre
#44
Salut jacum.
C'est a dire ? Tu as changé la vitesse de communication ?
Quelle vitesse as tu mis ?

Il me semble que le smx communique en modbus. Donc en effet c'est n'est pas le même protocole.
Répondre
#45
9600 Bauds, 8 Data bits, 1 Stop, No Parité.

Là où WatchPower est totalement muet, "Solar Station Monitor-Inverter-PC V1.6.exe " fonctionne un peu.

Reste à faire beaucoup de rétro-ingénierie...
Tout le monde voit quand j'ai bu, personne quand j'ai soif.
Répondre
#46
9600 c'est signe de modbus
Jean-Luc
Répondre
#47
Une simple recherche sur le forum aurait suffit a voir qu'on a développer le easun smx2 et que tu as juste a utiliser l addon smartphoton avec ton elfin ou tout simplement un cable usb imprimante qui fonctionne aussi sur ce modèle la, enfin je dis ça je dis rien Laughing
bishnoi aime ce post
Répondre
#48
ah oui et j'oubliais, oublie le dongle wifi, ou alors tu peux (suivant sa version) le formater et y installer esphome dessus pour extraire les données mais la on entre dans un registre encore plus sophistiqué.
Répondre
#49
(11-05-2024, 10:49 PM)gazzzzton a écrit : ah oui et j'oubliais, oublie le dongle wifi, ou alors tu peux (suivant sa version) le formater et y installer esphome dessus pour extraire les données mais la on entre dans un registre encore plus sophistiqué.

Bonjour,
À priori, dedans ce n'est qu'une ESP32... mais cette connerie vaut une fortune pour balancer toutes vos données vers un cloud chinois, très peu pour moi !

Dans la pub, c'était un onduleur "avec" WiFi, ils ne disaient pas que c'était à côté, ni ce que cela faisait.
Maintenant qu'il est là, aucune chance d'être remboursé, effectivement il mérite d'être reprogrammé, ce sera pour plus tard.

La EW11 fait parfaitement son job, je peux interroger l'onduleur sur mon réseau local.
Tout je job de parsing que j'avais fait pour l'ancien onduleur est à refaire avec le nouveau;
Sur l'ancien il suffisait de lui dire "QPIGS" pour obtenir tous les statuts, sous MODBUS c'est une autre histoire !!!

Je n'ai pas dû trouver la bonne page de ce forum, avec l'adresse des bons registres, je ne trouve même pas un exemple fonctionnel de modbus. HELP

L'onduleur répond, mais je ne trouve pas de réponse interprétable, par exemple:
Question en ASCII: 1 03 00 CA 00 03 25 F5
Réponse de l'onduleur: 7F 7E 6B F9 B5

J'ai encore beaucoup à apprendre.
Bon Dimanche
Tout le monde voit quand j'ai bu, personne quand j'ai soif.
Répondre
#50
Salut salut,

Pour ma part je trouve le modbus bien plus facile a intégrer.
Le problème c'est que il a beaucoup de modèles qui utilisent des adressage différents.

Nous avons commencé a intégré dans l'addon, on est un peu en stand-by pour le moment... D'autres projets mais déjà une bonne partie est disponible avec l'addon mais avec quelques erreurs ou capteur manquant.
Si tu souhaites essayer et nous remonter les défauts ça serait avec plaisir.

En ce qui concerne ce problème, je ne pense pas que wks Evo max utilise le modbus. A moins que ... ;)
Répondre
#51
(12-05-2024, 12:13 PM)NOLAK a écrit : En ce qui concerne ce problème, je ne pense pas que wks Evo max utilise le modbus. A moins que ...

Mon onduleur est un ISOSOLAR-SMX-II-5.6KP (SNRE), quel rapport avec wks Evo max ?
Est-ce encore un "rebranded" ? ou simplement un repeint sauvagement ?

En tous cas, il cause bien en 9600 bauds.

J'essayerai avec plaisir votre addon !

PS, bien qu’abonné, le forum ne me prévient pas par mail des nouvelles réponses à ce fil !
Tout le monde voit quand j'ai bu, personne quand j'ai soif.
Répondre
#52
Ce fils de discussion concerne le Evo max.
Donc je ne pense pas que ton problème soit le meme que celui de Folzo.
A moins que l'évo max soit aussi du modbus dans ce cas là il n'est pas encore compatible smartphoton.

Dans ton cas le smx a été en partie intégré dans l'addon. A moins que chez isosolar on leurs propres adresses.

Pour lire les données il faut lui envoyer l'adresse que tu veux ensuite, il te renvoie la valeur correspondante.

En ce qui concerne les adresses tu trouveras ton bonheur ici.
https://domosimple.eu/forum/thread-704.h...ight=Rs485

PS:
Il faut lui envoyer l'adresse en décimal pour qu'il te réponde correctement
Répondre
#53
Au vu des indications et photos sur ce fil tout me laissait croire que les pb étaient strictement identiques.
J'avais assez galéré avec l'ELFIN en son temps pour ne pas essayer d'éclairer un peu.
D'autre part, je viens de changer d'onduleur et mon premier essai fut de brancher un portable avec Watchpower... qui n'a pas voulu coopérer, ma EW10 non plus.
En fait il fallait une EW11.
J'ai mis sur le portable le logiciel SNRE, bien qu'un peu bugué, ça tourne.
Enfin j'ai conseillé un testeur de communication, mais pas de retour :(
En fait nous ne savons pas vraiment ce qu'on a quand on reçois un onduleur.
Je vous remercie des réponses et promis je ne pollue plus de fil.
Folzo aime ce post
Tout le monde voit quand j'ai bu, personne quand j'ai soif.
Répondre
#54
Il me semble que ew10 fait du modbus.
Pour watchpower c'est moins sûr. A vérifier

En ce qui concerne le smx et le mlv sont des bases snre, donc oui cela doit fonctionner.

Je t'invite a créé un nouveau sujet dans la bonne section du forum si tu veux continuer suite à tes tests
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)
[-]
Synthèse
Please login or register to use this functionality.

[-]
discussions récentes
Automatisation SOC
Ah super, merci. Bon je crois...gregmittel — 09:33 PM
clock matrice de Led Ulanzi p...
Ça me plaît bien ton truc fina...NOLAK — 08:39 PM
Automatisation SOC
Ok maintenant il faut faire un...NOLAK — 08:28 PM
Automatisation SOC
Hello. Ben déjà dans les gran...gregmittel — 06:21 PM
Automatisation SOC
Salut peux tu nous en dire plu...NOLAK — 05:41 PM
clock matrice de Led Ulanzi p...
La classe :cool:NOLAK — 05:40 PM
Redémarrage smartphoton
Pour moi, Smartphoton ne dois ...NOLAK — 05:29 PM
Redémarrage smartphoton
Du coup, cela ressemble plus a...jlm — 01:48 PM
clock matrice de Led Ulanzi p...
Alors ça y est, la vidéo expli...jlm — 12:59 PM
Redémarrage smartphoton
Dommage que tu n'ailles pas ...Sylvain — 12:01 PM
Automatisation SOC
Bonjour à tous. Je souhaitera...gregmittel — 11:55 AM

[-]
Rechercher








(Advanced Search)

[-]
Who's Online
There are currently 103 online users. [Complete List]
» 2 Member(s) | 101 Guest(s)
AvatarAvatar

[-]
goals
We've done it! We've made 6,000 posts! celebrate!
Goal Met!

[-]
Statistics
» Members: 567
» Latest member: RoBo32
» Forum threads: 649
» Forum posts: 5,995

Full Statistics

>